Random Notes‎ > ‎

Upgrading PostgreSQL Ubuntu package

posted Sep 23, 2011, 2:14 AM by William Shallum   [ updated Oct 2, 2014, 1:16 AM ]
I'm on Ubuntu 10.04 and was previously using the postgresql-9.0 package. Upgrade is to postgresql-9.1.

  • Install postgresql-9.1 package
  • Do *not* uninstall postgresql-9.0
  • Drop the new main cluster: pg_dropcluster 9.1 main --stop
  • Start the previous main cluster: pg_ctlcluster 9.0 main start
  • Upgrade the cluster: pg_upgradecluster 9.0 main
  • Test new cluster
  • If works, remove the old one: pg_dropcluster 9.0 main

See also: /usr/share/doc/postgresql-9.1/README.Debian.gz
Comments